seekrit squirrel

nerd central => Fruit => Topic started by: galumay on February 10, 2015, 08:43:09 AM

Title: Photo App
Post by: galumay on February 10, 2015, 08:43:09 AM
from our blog i quote my musings on the new Apple Photo App,

[ Invalid Attachment ]

sorry, this is a bit of a techy post, so those of you expecting more tales of travel, images of yummy food or photos of sublime wines may as well skip this one and save the disappointment!

recently apple announced they were discontinuing development of both iPhoto and more critically their pro photo app, aperture. it didnt come entirely as a surprise given apple's apparent disinterest in the needs of pro users - we had already seen the dumbing down of the video editing suite, Final Cut Pro, so the writing was on the wall.

as part of the release of the new operating system, yosemite, apple announced a new app called 'photos' which would replace both iphoto and aperture. i resolved to give it a try, despite my reservations, and this week the beta of the app became available thru a developer beta release of OS 10.10.3.

turns out it is not much good, surprise, surprise! its dumbed right down with lots of higher end editing features removed, its very much based around integration with iOS devices, with default photo streaming from all devices and built in sharing with popular services like FB & twitter. the problem is twofold, not only are pro type workflows broken by the weak editing 'features', but the integration and streaming is so built in and pervasive that retaining any real control over workflows is impossible.

I especially hate all the sharing, streaming, iCloud storage and integration defaults, i dont want my photo app filled with every image we take on all our devices across the family, i dont want to see kai's or sal's images on my iPhone, i dont want the iPhoto app to import and share every single image we take - most of which are crap anyway, and when i delete the crap ones i dont want the app to secretly store all the images i tried to delete!

I dont want to be using huge amounts of data for all the sharing, storing, iclouding and streaming, it never works properly anyway because the only place in the world with good enough internet plans to support all of this is probably south korea.

my needs are actually simple, a high powered photo organising app, that allows pro editing of images. i just want to connect our devices, import the images, delete the ones i dont want, be able to edit them and then export them for using in the blog, forum or storing on our smugmug gallery. I also want to be able to occasionally synch the devices so they have a selection of the recent images on them - the recent ones that have had the rubbish deleted and any edits done - in aperture that meant i synched the last 10 events.

aperture does all of this perfectly well, but the fact that apple will no longer support it or develop it means sooner or later i will have to migrate and sooner seems safer! so i thought i would give the new photos app a chance - but as i said it is so bad that it was actually completely disfunctional, so i gave up after a couple of days of trying to make it work at all.

the only viable alternative was adobe lightroom, and after initially having the same problem i always have with adobe apps - actually working out how to drive it, i realised its actually very good and does nearly everything i need really nicely.

[ Invalid Attachment ]

this is what the workspace for lightroom looks like.
it also made me reinvigorate our smugmug gallery to test the plugins for export to the gallery, i made a new gallery which is just a collection of the best of the images from our gap year, you can view them by scrolling through or play as a fullscreen slideshow by clicking on the slideshow button. The new gallery is HERE. i have upgraded the link in the links frame on the right hand side of the web page.

[ Invalid Attachment ]

what the new smugmug gallery looks like
so far the only thing I havent worked how to do is to synch recent images with the idevices like aperture does, but i suspect there will be a plug in to do it. if not i can see a workaround of synching to folders because the lightroom catalogue is organised by date folders so its not hard to synch the last couple of months if need be.

i still have to find a way to eradicate the vestiges of apple's photo app, every time i connect an i-device it tries to find its non existent folder and open up to import images - there is no way at this stage to 'turn it off' and you cant delete the app as its part of the OS.

Title: Re: Photo App
Post by: galumay on February 10, 2015, 09:30:34 AM
Ok so I have solved the synching recent images issue with Lightroom, pretty straightforward really, create a new publish service in Lightroom,

[ Invalid Attachment ]

You can choose your own presets, this is based on an iPhone 6+ and i wanted a folder in the Pictures folder on the user volume that I could synch iTunes with the iPhones.

Then i created a smart collection to gather together the images from the last 2 months to be published,

[ Invalid Attachment ]

so i went to the publish location i had created and right clicked on the 'pictures' to get the dialogue box to create the smart collection,

[ Invalid Attachment ]

Final step is to name it and configure to add last 2 months images.

Then its just a matter of clicking on the iPhone publish service smart collection, hitting command A to select all images in the selection and clicking the publish button.

I hooked the iPhone up, directed iTunes to the folder of photos called iPhone I had created in the Pictures folder and applied and synched. Wallah!

[ Invalid Attachment ]
Title: Re: Photo App
Post by: galumay on July 24, 2015, 04:50:19 PM
Title: Re: Photo App
Post by: galumay on September 16, 2015, 09:24:18 PM
The above also seemed not to work, I suspect its related to what i discovered about Apple's new security processes. In the end i have just deleted as described below,

Ok, I have discovered that what Apple have done is to add a whole new layer of security to 10.11, that either users will never know about or alternatively, actively not want - go figure! 

They have taken away some privileges from root. The that I am trying to delete has a restricted flag. Now only restricted processes which are signed by Apple will be able to modify files . However, you can disable this security system by booting in recovery mode and disabling it in a Terminal by running: csrutil disable.

I just used AppZapper after that to remove but equally you could run the Terminal command to delete.